Решение задач типа В3 ГИА по информатике

Тема - "Про­стей­ший циклический алгоритм, за­пи­сан­ный на ал­го­рит­ми­че­ском языке"

Задача. За­пи­ши­те зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы. Текст про­грам­мы при­ведён на трёх язы­ках про­грам­ми­ро­ва­ния.

 

Ал­го­рит­ми­че­ский язык Бей­сик Пас­каль
алг

нач

цел s, k

s := 0

нц для k от 4 до 8

s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 4 TO 8

s = s + 7

NEXT k

PRINT s

 

Var s,k: integer;

Begin

s := 0;

for k := 4 to 8 do

s := s + 7;

writeln(s);

End.

 

 По­яс­не­ние.

Цикл «for k := 4 to 8 do» вы­пол­ня­ет­ся пять раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 7. По­сколь­ку из­на­чаль­но s = 0, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 7 · 5 = 35.

Задача. За­пи­ши­те зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы. Текст про­грам­мы при­ведён на трёх язы­ках про­грам­ми­ро­ва­ния.

 

Ал­го­рит­ми­че­ский язык Бей­сик Пас­каль
алг
 нач
 цел d,n
 d := 6
 d := d-2
 нц для п от 1 до 4
 d : = d + n
 кц
 вывод d
 кон
DIM n,d AS INTEGER
 d = 6
 d = d-2
 FOR n = 1 TO 4
 d = d + n
 NEXT n
 PRINT d
Var d,n: integer;
 Begin
 d := 6;
 d := d-2;
 For n := 1 to 4 do
 d : = d + n ;
 Writeln(d);
 End .

 По­яс­не­ние.

Цикл «for n := 1 to 4 do» вы­пол­ня­ет­ся че­ты­ре раза. Каж­дый раз пе­ре­мен­ная d уве­ли­чи­ва­ет­ся на n. По­сколь­ку из­на­чаль­но s = 6 − 2 = 4, после вы­пол­не­ния про­грам­мы по­лу­чим: d = 4 + 1 + 2 + 3 + 4 = 14.

 Ответ: 14.


Оставить комментарий

Комментарии: 4
  • #1

    rytuał miłosny (Вторник, 11 Апрель 2017 01:08)

    rytuał miłosny

  • #2

    Female Viagra (Пятница, 14 Июль 2017 20:49)

    Malegra DXT

  • #3

    sex telefon (Четверг, 10 Август 2017 23:25)

    купить виагру

  • #4

    пиздец ибац (Воскресенье, 06 Май 2018 01:19)

    пиздец ибац